Cloudflare

Managed OAuth for Access: make internal apps agent-ready in one click

Apr 14, 2026Eduardo Gomes, James Royal, Ann Ming Samborski
Managed OAuth for Access: make internal apps agent-ready in one click
SummaryAI, from the source post

Introduces managed OAuth for Cloudflare Access applications, allowing agents to authenticate using OAuth 2.0 flows (RFC 9728, RFC 7591, RFC 7636) by discovering authorization server information at /.well-known/oauth-authorization-server. This eliminates the need for service accounts and static credentials for agent access to internal applications, ensuring actions are attributable to human users and enabling agents to interact with web pages, web apps, and REST APIs behind Access policies.

More from the Account Access Management & Permissions trail